File Naming

File naming / Importing images / Output naming / Batch rename

Capture One offers extensive file naming and renaming options, including the use of dedicated tokens for dynamically created file names and folder generation based on the libaries within Catalogs and Sessions and certain image metadata. You can also create customized filename options and presets depending on your particular needs.

 

Adopting tokens in naming dialogs

In addition to adding text in the usual way in the naming dialogs, many of Capture One’s text-based tools such as the Naming and Destination/Location (and Keyword) tools feature dialogs where you’ll find tokens. These gray-colored, tablet-like elements create text from the image file’s metadata. In some cases the tokens can access other data within the individual Session or Catalog such as the Document name itself or its Collection name.

For example, if you add the Image Date (MMM dd yyyy) token, Capture One will take the capture date from the images’ metadata. If it is used to rename image files, it will replace the original file name with the chosen date format (e.g., Jun 14 2018). You can type custom text between the tokens and use the keyboard's underscore key (_) to separate multiple tokens and custom text from becoming a continuous name.

When the same token is used in the Location Sub Folder field it works in a similar way, but it doesn’t just create and name a folder in the same format, it will also populate those folders with the relevant images.

Dynamically naming folders and files

The real power of the Location Sub Folder option is revealed when multiple tokens are used with a forward/backslash (macOS/Windows) delimiter between them. Then Capture One will automatically create and organize the images in a series of hierarchical folders, with each one being named dynamically from the metadata.

For example, when the three separate Image Year (yyyy), Image Month (MMM), and Image Day of Month (dd) tokens are used together a similar naming format will be built. However, when the delimiter is applied between them, top-level folder is created for the year, with sub-folders for the months, each created dynamically based on the metadata in the images. Inside that folder sub-folders will be built for each day, and Capture One will also populate those folders with the relevant images.

When you combine naming and location tokens (and custom text) in their respective tool dialogs, Capture will organize and rename files and folders based on the criteria specified, enabling you automate the some of the most repetitive routines.

If you already adopt the popular date folder hierarchy in the example above or have something similar, think how you can customize the Location Sub Folder to mimic it and Capture One will integrate the creation of the new folders without overwriting the existing ones.

Name files when capturing

  1. In the Next Capture Naming tool click the button next to the Format text box to get the token name dialog box.
  2. Select the desired naming choice in the Presets dropdown menu. Alternatively, create a new naming format by dragging tokens and/or adding custom text to the Format text box.
  3. Click the downward arrow on Tokens to access and select more options. 
  4. Click OK to accept the changes.
  5. Verify that the sample below the Format text box is the desired format.

Name files when importing images

  1. Select File>Import Images… from the menu or click the Import icon.
  2. In the Naming tool click the button next to the Format text box to get the Naming dialog box.
  3. Select the desired naming choice in the Presets drop down menu. Alternatively, create a new naming format by dragging tokens and/or adding custom text to the Format text box.
  4. Click the downward arrow on Tokens to access and select more options.
  5. After choosing the desired token, drag and drop the token into the format line.
  6. Click OK to accept the changes.
  7. Verify that the sample below the Format text box is the desired format.

Name output files when processing images

  1. Go to the Output Naming tool (in the Output Tool Tab) and click the button next to the Format text box.  A Naming Format dialog box will appear.
  2. Select the desired naming choice in the Presets drop down menu. Alternatively, create a new naming format by dragging tokens and/or adding custom text to the Format text box.
  3. Click the downward arrow on Tokens to access and select more options.
  4. Click OK to accept any changes.
  5. Verify that the sample below the Format text box is the desired format.

Note: To add a Job Name, add text in the field and add the Job Name token to the Format field. Adding a Sub Name token adds a suffix to the file name from the Process Recipe tool.

Change output naming settings

  1. Go to Output Naming tool in the Output Tool Tab.
  2. To remove unwanted Tokens, click on them in the Format text field and press backspace/delete (Mac/Windows). Alternatively, open the Naming Format dialog, by clicking on the Format action icon (...) and delete them from there.
  3. Drag and drop new Tokens into the desired order in the Format field of either of the two naming dialogs. Note, some Tokens provide a drop down menu with more options.
  4. Press OK to accept the changes.

Create custom naming presets

  1. Create a custom format by dragging tokens and/or adding custom text to the Format text box in the Naming dialog box.
  2. Select Save Use Preset… in the Presets drop down menu or at the bottom of the Naming Format dialog box.
  3. Name the Custom Preset and click OK.

Rename multiple files (Batch Rename) Pro

  1. Select Multiple (thumbnail) images in the Browser.
  2. Choose Image > Batch Rename Images… or ctrl-click (Mac) / right-click (PC) and select Batch Rename… to open the Batch Renaming tool. 
  3. Text and Tokens is selected by default under the renaming Method option, however, certain image files can be singled out from large batches and renamed using the Find and Replace option (see below for details). 
  4. Click the [] button next to the Format text box to get the Naming Format dialog box.
  5. Select the desired naming choice in the Presets drop down menu. Alternatively, create a new naming format by dragging tokens and/or adding custom text to the Format text box.
  6. Click the downward arrow on Tokens to access and select more options.
  7. Click OK to accept the changes.
  8. Verify that the sample below the Format text box is the desired format.
  9. Click Rename to start renaming all the selected images.

Rename multiple files using Find and Replace

Multiple image files can be singled out from large batches and renamed using the Find and Replace option. This option can be used very effectively to rename part of the file name.

  1. Select a group of images in the Browser that you want to search within. 
  2. Choose Image > Batch Rename Images… or right click and select Batch Rename…to open the Batch Renaming tool.
  3. From the Method text box, select Find and Replace from the drop-down menu.
  4. From the Find text box, type the file name to be searched for and then rename the file(s) in the Replace text box.
  5. Be sure to verify the proposed renaming format in the Sample field.
  6. Click the Rename button to accept the changes and start the renaming.

Controling the counter

You can control the counter separately for capture naming, image import naming, output naming and batch renaming. This is done from the main menu or, alternatively, by clicking on the action [] menu in the used tool.

In this example, we will change the counter for the Rename Counter, but the same applies for the Capture Counter, Import Counter, Output Counter and Export Counter:

Select File > Rename Counter > Reset Counter to reset to counter back to zero.

Select File > Rename Counter > Set Counter… set the starting number.

Select File > Rename Counter > Set Increment to control the increment of the Counter.

Renaming file extensions (macOS only)

When using the Rename or Batch Renaming options Capture One doesn’t typically allow the renaming of the file extension. There’s no real need and doing so may corrupt the file. However, Phase One digital back file formats include a .TIF (RAW) file extension that’s interchangeable with the more typical .IIQ RAW file extension.  If you want to update one to the other, you must first enable the option in the batch Renaming tool’s action menu, and then add the text in the Format field. Although intended for batches, the tool will rename single files.

Warning! Please make sure you have a file backup available before proceeding. Do not use with other extensions in case of file corruption and data loss.

  1. Select the image or images in the Browser with the .TIF/.IIQ file extension.
  2. From the main menu select Image > Batch Rename Images… Alternatively, ctrl/right-click, from the contextual menu, select Batch Rename. The Batch Renaming tool opens.
  3. Click on the Action menu button (… icon) in the tool’s title bar. The Action menu opens.
  4. Select Include File Extension to enable with a check mark.
  5. From the Method field choose the appropriate option for the renaming task (i.e., Text and Tokens or Find and Replace).
  6. In the resultant Format or Find and Replace fields, add text and/or tokens as appropriate and type .TIF/.IIQ file extension without a space between.
  7. Select Rename. The selected image’s file names and extensions will be renamed.