Sequences (Phase One XF system camera only)

Sequences / Dynamic locations / Metadata

This section covers the new Sequences feature for the Phase One XF system camera and how you can use it to automatically name files and create sub folders, search and group images together from a number of related photos.

An overview of sequences

A Sequence is a series of related photos captured using certain features available on the Phase One XF series camera. The Hyperfocal Distance tool and the new Time Lapse, High Dynamic Range (HDR) and Focus Stacking functions introduced with Feature Update #2 all create Sequences automatically.

After you’ve captured a series of images or Sequence using one or more of the new tools, you’ll almost certainly want to view the photos together and customize your workflow around them. Sequences allow you to do that and more.

When you import images from a CompactFlash card or directly with a tethered Phase One XF series camera, Capture One can identify those Sequences by the metadata recorded by the camera at the time of capture. The camera tags the RAW files with the following properties:

  • Sequence ID: Unique identifier (i.e., IQ back serial number and initial frame number of each sequence).
  • Sequence Type: Tool in use (e.g Hyperfocal, HDR, Focus, Time lapse).
  • Sequence Count: frame count shown as position (e.g., position 3 (of 7 ).
  • Sequence Total: frame count shown as total (e.g sequences comprising of 7 images). 

Capture One can use this data in a number of ways:

In addition to the Hyperfocal Distance tool introduced in the previous update, Feature Update 2 introduced new Time Lapse, High Dynamic Range (HDR) and Focus Stacking tools.

Tokens and dynamic locations

When importing from a CompactFlash card, or when using the XF camera tethered, Capture One can automatically name photos and folders using the Sequence properties. You can use one just one property or any combination of the four in the naming of Sequences. The same tokens can be used for batch re-naming, or for naming on export.  As part of Capture One’s Dynamic Locations feature, they can be used to automatically create named sub-folders for each Sequence, either on import, export or both. 

After import, photos will appear in the Browser in order of capture. To differentiate a Sequence from other non-sequence captured photos, a multi-frame icon is displayed in the lower left corner of each image in the Filmstrip and Grid views. In the List view, the Browser shows the Sequence ID in order of capture.

Metadata

When an image is selected, the sequence count, total type and ID can be determined from the Vendor Specific drop-down section of the Metadata tab under Sequence ID and Sequence Info. When using the HyperFocal AF mode on a tethered Phase One XF camera system, the HyperFocal MCU value is recorded during capture and is displayed in the Description field under the IPTC - Content section.  After checking the multiple images for focus accuracy in the Viewer, you can manually transfer the MCU value from the optimal image to the camera. See the XF owner’s manual for more information on the Hyperfocal distance tool.

Creating sequence sub-folders on import

When importing images from a CompactFlash card from the Phase One XF system camera and one or more Sequence has been captured, Capture One can automatically create and name sub-folders based on the metadata properties of the Sequence.

For example, when you have captured 10 HDR Sequences and then import them using the Dynamic Location Token for Sequence ID, Capture One can automatically create and name a sub folder for each HDR bracket, or Sequence.

  1. Click on the Import button to open the dialog, and select only the images that are known to form a Sequence or a series of Sequences. 
  2. In the Import To tool, select where to store the imported images from the Store Files fly-out menu.
  3. Adjacent to the Sub Folder field, click on the Location Sub Folder Tokens button (…). The Location Sub Folder Tokens dialog opens.
  4. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when just the Sequence ID token is used, a sub-folder is named and created for each individual sequence. When the Sequence Type token is placed in front of the Sequence ID with a forward or back slash (Mac/Windows) between them, the individual Sequence sub-folders are enclosed by a folder denoting the Sequence Type (in this case, if only HDR type sequences were captured, the enclosing folder would be HDR with ID subfolders).
  5. Click OK, and continue with your usual import workflow.

Note: When images are included on the CompactFlash card that aren’t part of Sequence, re-open the importer and import images using a more relevant folder naming format. 

Naming a sequence on import

When importing images from a CompactFlash card from the Phase One XF system camera and one or more Sequence has been captured, Capture One can automatically name the images based on the metadata properties of the Sequence.

  1. Click on the Import button to open the dialog, and select only the images that are known to form a Sequence or a series of Sequences.
  2. Follow your usual workflow with the Importer.
  3. In the Naming tool, click on the Naming Format button () to the right of the text field. The Naming Format dialog opens.
  4. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when all four tokens are used in that order with underscore to separate them, the file name format will look like this: Focus Stacking_ABC0123_0011732_3_5.IIQ. This series identifies this image as the 3rd in a 5 frame Focus Stack, and details the serial number and unique ID of the Sequence.
  5. Verify the name is in the desired format in the Sample text field.
  6. Click OK, and continue with your usual workflow.

Note: When images are included on the CompactFlash card that aren’t part of a Sequence, re-open the importer and import images using a more relevant naming format.

Naming a sequence when tethered

When a Sequence is being captured with a tethered Phase One XF system camera, Capture One can automatically name the images during import based on the metadata properties of the Sequence.

  1. Follow your usual workflow when working tethered.
  2. In the Next Capture Naming tool, click on the Naming Format button (…) to the right of the text field. The Naming Format dialog opens.
  3. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when all four tokens are used in that order with underscore to separate them, the file name format will look like this: Focus Stacking_ABC0123_0011732_3_5.IIQ. This identifies this image as the 3rd in a 5 frame Focus Stack, and details the serial number and unique ID of the Sequence.
  4. Verify the name is in the desired format in the Sample text field.
  5. Click OK, and continue with your usual workflow.

Batch renaming using sequences

  1. Select the Sequence in the Browser.
  2. Choose Image > Batch Rename Images…or ctrl-click (Mac) / right-click (PC) and select Batch Rename… to open the Batch Renaming tool. 
  3. From the Method fly-out menu, confirm the Text and Tokens option is selected (default).
  4. Click the () button next to the Format text field to open the Naming Format dialog box.
  5. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when all four tokens are used in that order and using underscore to separate them, the file name will look like this: Focus Stacking_ABC0123_0011732_3_5.IIQ. This identifies this image as the 3rd in a 5 frame Focus Stack, and details the serial number and unique ID of the Sequence.
  6. Click OK to accept the naming format
  7. Verify the name is in the desired format in the Sample text field.
  8. Click Rename to start renaming all the selected images.

Searching for sequences

You can search any collection for image Sequences using the Filters tool to find the Sequence metadata assigned at the time of capture by the Phase One XF camera system. You can search by Sequence Type, ID, Count and Total.

  1. In the Library Tool tab, select a collection you want to search.
  2. From the Filters tool, click on the action menu () and select Show/Hide Filters... A Metadata Filters dialog opens.
  3. Select the Sequence type you want to search by (all four types can be added). The relevant search dialogs are added to the Filters tool.
  4. In each dialog, Sequence data is shown alongside the number of images that match the search criteria.
  5. Select the type of images you’re searching for (e.g., Sequence Type > Hyperfocal) and click on the adjacent numbered radio button. The button is highlighted in orange (when the search is active) and the total number of images are immediately displayed in the Browser.
  6. To clear the search, click on the active (orange) radio button, returning it to black. All of the images in the collection are displayed in the Browser once more.

Selecting sequences

Any Sequence can be selected from the Browser and isolated from other non-related images to get an overview and help with the initial organization. Photos are displayed in succession, unless images have been manually rearranged (i.e., the sort order has been changed).

  1. Click-on an image in the Browser that’s a part of the Sequence you want to select. A small multi-image file icon, located bottom left in a thumbnail in the Browser, indicates the image is part of a Sequence.
  2. Go to the menu and choose Select > Select By Same, then choose Sequence ID.
  3. All the images in the Sequence are displayed in the Viewer (and selected in the Browser). (Note that Multi View option must be enabled in the Viewer bar.) During selection, the sort order cannot be altered.
  4. To navigate through the Sequence without selecting other non-related images, you can use the optional Select buttons on the main Toolbar, or forward / backward arrow keys on the keyboard.

Creating an album from a sequence

After a Sequence has been selected you can save the Sequence as an Album. When there are multiple Sequences, you can select an entire import, or collection and create multiple Albums automatically, saving time and effort organizing the sequences into their respective groups.

  1. Select an image from a chosen Sequence in the browser, or, to make multiple albums, select all the images in a collection.
  2. Go the menu and select File > Create Albums From, and choose Sequence ID.
  3. Albums are created by Sequence ID in the Library tool (under User Collections in a Catalog, and as Sessions Albums in a Session).
  4. Click on the new Album to reveal the Sequence in the Browser.

 

Creating sequence sub-folders on export

When exporting images Capture One can automatically create and name sub-folders based on the metadata properties of the Sequence. For example, you have captured 10 separate Focus Stacking Sequences, made some preliminary edits and now want to export the images for merging and rendering. Capture One can process the images and automatically create and name a sub-folder for each Focus Stacking Sequence.

Automatically naming and creating sub-folders on export using Capture One’s Dynamic Locations feature can be achieved on an improvised basis using the Process Recipe tool (using Sequence tokens in the Sub Folder text field). However this is a specialized tool intended to make presets and this particular option is useful when creating sub-folders by file format (using Recipe Name tokens). Best practice when creating Sequence sub-folders is to use the Output Location tool instead.

  1. Select the images for export and choose the appropriate recipe or multiple recipes. Note, the Root Folder option in each chosen recipe must defer to the Output Location tool.
  2. In the Output Location tool, click on the Sub Folder button () to the right of the text field. The Location Sub Folder Tokens dialog opens.
  3. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when just the Sequence ID token is used, a sub-folder is named and created for each individual Sequence. When the Sequence Type token is placed in front of the Sequence ID with a forward or back slash (Mac/Windows) between them, the individual sequence sub-folders are enclosed by a folder denoting the Sequence type (in this case, if only Focus Stacking type sequences were captured, the enclosing folder would be labeled Focus Stacking and include ID sub-folders).
  4. In the Sample text field verify the name is in the desired format.
  5. Click OK, and continue with your usual export workflow.

Naming images on export using sequences

Naming images on export can be achieved on an improvised basis using the Process Recipe tool (using Sequence tokens in the Sub Name text field and providing a complementary Sub Name token is used in the Output Naming tool). However it is a specialized tool intended to make presets. Best practice is to use the Output Naming tool instead.

  1. Select the images for export and choose the appropriate recipe or multiple recipes.
  2. In the Output Naming tool, click on the Naming Format button () to the right of the text field. The Naming Format dialog opens.
  3. Select from the combination of four Sequence Naming tokens (Sequence Type, ID, Count and Total). For example, when all four tokens are used in that order and using underscore to separate them, the file name will look like this: Focus Stacking_ABC0123_0011732_3_5.IIQ. This identifies this image as the 3rd in a 5 frame Focus Stack, and details the serial number and unique Sequence ID.
  4. Verify the name is in the desired format in the Sample text field. Note, for convenience when repeatedly using the same tokens, you can save the combination as a User Preset (as shown).
  5. Click OK, and continue with your usual export workflow.

Exporting sequences to Helicon Focus ®

When capturing image sequences destined for focus stacking you can use Capture One to select the appropriate sequence (see above) and then export the images to the dedicated focus stacking application, Helicon Focus ®, by Helicon Soft Ltd.

Be aware that Helicon Focus is a third-party application and a separate license is required from Helicon focus, please see more at www.heliconsoft.com. To install Helicon Focus, go to the Capture One 12 Preferences and select Plugins, then click on the button on the lower right corner to install the plugin.

The Helicon Focus plugin for Capture One provides a fully automatic roundtrip workflow for Helicon Focus from HeliconSoft.

As an addition to the Focus Stacking feature in the Phase One XF Camera System, this plugin provides a simple and easy workflow to create stunning images with infinite depth of field. Read more about the XF Focus Stacking feature in the XF Camera System Manual available here

Helicon Focus operates directly on the RAW file, by processing them, and exporting the result to Helicon Focus, and then import the result back into the same folder.

When capturing image sequences destined for focus stacking you can use Capture One to select the appropriate sequence and then export the images to the dedicated focus stacking application, Helicon Focus ®, by Helicon Soft Ltd.

Process RAW files and export to Helicon Focus

    When capturing image sequences destined for focus stacking you can use Capture One to select the appropriate sequence of images.

    If the images are captured using Focus Stacking Tool on the XF Camera you can select them by Sequence ID (metatag). Select one of the images from the sequence and then choose Select > Select By Same > Sequence ID. All of the images with the same Sequence ID are now selected.

    Otherwise you will have to select the images manually. When the images are selected, they can be sent to Helicon Focus by going to the menu and choosing Image > Edit With > Stack in Helicon Focus.

    A dialog now opens. It will let you setup the output file that are used in Helicon Focus and some basic adjustments, please go through the tabs to verify that settings are as you want them to be.

    The Keep processed variants can be checked if you want to store the processed work-files in order to have a faster workflow for re-processing the images through Helicon focus at a later time (please see below). When things are setup as you would like them to be, click on the Edit Variants.

    Now the selected images will be processed and imported into Helicon Focus, and Helicon Focus will be opened.

     

    In Helicon Focus, you should select your rendering method, (please refer to the Helicon Focus Documentation) and click > Render.

    Once the Stacking image is rendered, you should click save, and the dialog will point you into the original capture folder. Save your image here and exit Helicon focus.

     

    Back in Capture One, you should now see your finished image, plus the saved variants, if you selected to keep them.


    Using Helicon Focus® on processed variants

    If you have selected Keep processed variants in the Helicon Focus dialog box (see above), Capture One is saving all the processed variants that are used for the focus stack. These will be placed in the capture folder.

    This can be an advantage if you want to process the files through Helicon Focus again, without having to develop all the raw files again, which can be a time-consuming task if it involves many images.

    In order to run the variants through Helicon Focus again, you should use the menu Open With command. Select all the variants, then go to the menu and select Open With > Helicon Focus.

    This will bring those images directly into Helicon Focus, and you can redo your processing in there in the exact same way as in the original Edit With workflow (see above).

    Export JPEG/TIFF files to Helicon Focus

    1. Select the previously processed images (with either .jpg or .tif file extension) required for stacking. You can do this either individually, or, by selecting one image from the appropriate sequence of processed images and choosing Select > Select By Same > Sequence ID. All of the images with the same Sequence ID are selected).
    2. Choose Image > Open With, and select Helicon Focus from the list.
    3. Render the files in Helicon Focus (as directed in the developer’s instruction manual) and name and save the file as appropriate.
    4. The rendered file will be returned to the originating image folder (e.g., the Selects Session Folder) in Capture One by default and displayed in the browser.