Working with Layers and Masks

Layers / Layer Adjustment / Mask

When more complex editing is required, Capture One’s Layers tool enables you to combine brush adjustments, gradients and repairs to masked areas using multiple layers.

Overview of layers and masks

The tools in Capture One typically apply global adjustments to the whole image, however there are times when you want to perform corrections to a specific part of the image. For example, you might want to simply sharpen the eyes in a portrait, fix some blemishes or apply a graduated filter effect.

There are three ways to create a mask: Painting with a brush or by creating either a Linear Gradient Mask or a Radial Gradient Mask that is non-destructive in nature and therefore can be readjusted easily at any given time. They can all be accessed from either the Layers tool, the Cursor toolbar, or by using their assigned keyboard shortcuts.

The most versatile is the brush tool, called Draw Mask. This lets you apply adjustments to specific areas in an image by painting a mask over the desired areas. The Linear Gradient Mask and the Radial Gradient Mask on the other hand works by creating a gradient area that you can always readjust: They are applied in a non-destructive fashion, meaning that you can always change the size, shape, rotation, feathering and position of the mask after the fact.

Once a mask has been created you apply the image adjustments in the same way as you would when making global adjustments. You can make any combination of image adjustments from different tools on the same Layer mask, so nothing prevents you from tweaking both Exposure, Clarity and Color Balance to one specific Layer mask.

If you need to apply a number of localized image adjustment to different parts of the image, just create a new layer with a separate mask. You can create as many as 16 individual layers per image.

Creating and selecting layer types

You can create a mask and layer in one go simply by selecting and using eitherDraw Mask (B), Linear Gradient Mask (G) or Radial Gradient Mask (T) there might be times where it is better to create and name individual layers first to get organized. This is especially true when you need to use the clone or heal tools to repair images as they can only be accessed through dedicated clone or heal layers.

  1. Go to the Layers tool or and long-press on the create New Layer button (+) icon and select from the following choices:
    • New Empty Layer - New layer without mask using the brush or gradient for image adjustments.
    • New Filled layer - New layer complete with a mask covering the whole image. Used for brushing away adjustments, or brushing away the mask, when it is the simpler option.
    • New Clone Layer - New layer specifically for repair using the cloning brush.
    • New Heal Layer - New layer specifically for repair using the heal brush.

or:

    1. Go to the Layer menu and select from the following choices:
      • Add New Empty Adjustment Layer - New layer without mask using the brush or gradient for image adjustments.
      • Add New Filled Adjustment layer - New layer complete with a mask covering the whole image. Used for brushing away adjustments, or brushing away the mask, when it is the simpler option.
      • Add New Clone Layer - New layer specifically for repair using the cloning brush.
      • Add New Heal Layer - New layer specifically for repair using the heal brush.
  1. The layer type is added to the Layers tool (press return to enter a new name), and to the drop-down menu in the Viewer’s tool bar.
  2. Draw a mask on the image. Select mask visibility as required. See here for more details.
  3. When selecting the Heal or Clone Layer options, Capture One automatically selects the source point after drawing. If the appearance of the target area doesn’t match the surrounding pixels, click on the source point and drag it to set your own sampling point. The source point can be moved anywhere within the viewer. For more information, see the Repairing Images section.
  4. Remember to select the Background Layer in the Layers tool, or Viewer’s tool bar, to make any global adjustments to the image.

Creating a new filled layer

The New Filled Layer option adds a new layer complete with a mask covering the entire image. This makes it inherently useful for several labor-saving tasks, such as when adding adjustments to the whole image except for small areas which can be brushed away with the Erase Mask (E) or when applying baseline adjustments in normalized workflows, color grades or simple auto adjustments, using a layer for each like versions within a variant. 

  1. Select an image.
  2. Go to the Layers tool and long-press on the create New Layer button (+) icon and select New Filled Layer or go to the menu and select Layer > Add New Filled Adjustment layer.
  3. A new layer complete with a mask is created and added to the Layers tool (press return to enter a new descriptive name).
  4. Select the layer, if not already and add the chosen adjustment such as a color grade using the Color Balance tool or a Style or Preset (using the Apply settings to a current layer option) available from the Layers tool action menu. The applied adjustment is saved to the layer.

Deleting a layer

The Layers tool allows you to quickly delete a Layer along with any masked areas and adjustments applied. Warning! Deleting is immediate, however you can undo the command if selected inadvertantly; from the main menu, select Edit > Undo (cmd/ctrl+z)

  1. Select the image or images in the Browser.
  2. Go to the Layers tool and select the relevant adjustment layer from the list (when selected the bar will be orange or silver-colored, depending on focus).
  3. From the Layers tool, click on the Delete Layer button (- icon). Warning! The layer is deleted immediately along with masked areas and adjustments.
  4. The selected Layer is deleted.

Working with multiple layers

Layers are an essential feature for images that require complex adjustment. You can have as separate as 16 separate layers associated with one image. Each layer will be displayed in a list or stack in the Layers panel, along with a description of its type, master opacity and a checkmark indicating that the layer is enabled. To see the effect of the layer on the image and, therefore, the masked selection and any adjustments or repairs applied, simply toggle the checkmark on/off next to the layer. When enabled, Selection Points for each Layer are visible in the Viewer, you can use them to switch quickly between them without a returning to the Layers panel.

Clicking on the Create New layer button adds a layer to the top of the stack. Layers aren’t linked in the stack, so you can freely move them up or down to organize them. Simply click and drag it up or down the stack to reposition. Layers can be renamed by clicking on their name or hit Enter on the keyboard. A layer is selected when it has an orange bar, and you can then perform commands from the Layers tool and Action menu. When the layer bar is silver, the layer is selected but focus has moved away to other actions or tools, such as when drawing masks or applying adjustments to that layer. Layers can be quickly discarded by selecting in the stack and pressing the Delete Layer button, though this will also delete any selections and adjustments, or repairs made.

Switching between layer types

Capture One has three types of layers: Adjustment for image adjustments and Heal or Clone for retouching. They are marked by different icons on the layers in the Layers tool. If you do mistake create the wrong layer type or you change your mind, you can easily switch between them.

  1. Select the layer you want to change in the Layers tool.
  2. Click on the Layer type drop-down menu.
  3. Select the new layer type from the list (note the different icons)
  4. You can verify that the layer is switched by checking that the type icon is changed.

Creating a mask

When you apply either the Draw Mask (B). Linear Gradient Mask (G) or the Radial Gradient Mask (T) to an image, the Layers tool automatically creates a mask from the selection, along with an adjustment layer. You can then make your localized image adjustments.

If you have created an empty layer first, you apply the desired image adjustments first as see them being applied as you draw the mask.

Read how you create and adjust a mask with the Draw Mask (B) here

Read how you create and adjust a mask with the Linear Gradient Mask (G) here

Read how you create and adjust a mask with the Radial Gradient Mask (T) here

Note when you want to remove blemishes, you will have to select either a clone or heal layer from the Layers tool or Viewer’s tool bar. See the section on Repairing Images for more details.

Deleting a mask

Capture One offers a clear mask option for the Layers tool that allows you to quickly delete the mask without using either the eraser or deleting the adjustment layer itself. As this option only deletes the masked areas on the selected layer on the chosen image, regardless of the number of variants selected, it is particularly useful when you’ve applied adjustment settings or a Style or Preset to multiple variants and you don't want that choice affecting the others.

  1. Select the image or images in the Browser.
  2. Go to the Layers tool and select the relevant adjustment layer from the list.
  3. Right-click on the layer and choose Clear Mask from the list.
  4. Any masked areas are removed from the selected Layer only. The Layer itself is not deleted.

Copy a mask to another layer

Although you can apply more than one image adjustment to the same masked area, you might want to add a different adjustment to exactly the same area of the image and retain separate control over each mask on different layers. This can be done by copying a mask to another layer.

Note that the function will overwrite an existing mask without warning, so if you have a lot of layers, double check that you are copying to the correct layer first.

  1. Go to the Layers tool.
  2. Create a new layer or select an existing layer you want the mask to be copied to. For example, Layer 2.
  3. Right-click on that layer and select Copy Mask From > Layer No. (e.g., Layer 1). The mask will be copied and applied to Layer 2.
  4. The copied mask can now be adjusted further, and you can apply the desired image adjustments.
Note that you can copy a Linear Gradient Mask (G) or Radial Gradient Mask (T) to another layer and still retain the possibilities to readjust the mask on the new layer. This can provide a powerful workflow if you just need to tweak the coverage of the mask slightly on that new layer.

Fading adjustments

The Layers tool features a master Opacity slider, which enables you to lower or fade the amount of one or more local adjustments already applied to the mask, without altering the adjustment tools individually. The master Opacity slider is located beneath the title bar in the Layers tool. Selecting a layer enables the Opacity slider for use with only that layer. Only one can be adjusted at a time, and all the masks applied to the layer will be adjusted by the same value. When working on an image with a number of layers comprising of complex masks and adjustments, you can modify the effect of each layer very quickly. Next to the slider is a box where you can enter a value (%), either directly, or by using the arrow keys (use Shift+arrow keys to modify the amount by larger values). To save a result and compare the effects between adjustments, remember to use the Clone Variant option.

  1. Go to the Layers tool.
  2. Select the layer in the list with the adjustment you want to fade. (The mask should already have some local adjustment applied to it.) The master Opacity slider is then enabled.
  3. Drag the master Opacity slider while observing the effect on the image in the Viewer. Alternatively, select the the text box and enter a value directly, or select then use the arrow keys (or Shift+arrow keys) to adjust by fixed values. The image will be similarly updated with the effect in the Viewer.
  4. When the slider is moved the mask will be hidden (regardless of the visibility setting selected), so that you can see the effect of the applied local adjustment on the image. The mask reappears after a short delay.

Displaying masked areas

Being able to see the mask on-screen is crucial when making accurate selections, while at other times, for example, when brushing-in adjustments, it can obscure your view. Thus, when using the Draw Mask (B), Linear Gradient Mask (G) or Radial Gradient Mask (T), the Layers tool has several display options to suit a particular task.

After the mask has been applied you can evaluate the selection more clearly with a grayscale mask. This black and white preview shows the masked area in white, unmasked as black and gray tones depending on opacity. It is ideal for inspecting edge accuracy and the uniformity of the selection itself with regards to opacity. The masked area itself can be tidied up using either mask type.

  1. Go to the Layers tool.
  2. Long-click on the Mask button, and select from the following:
    • Always Display Mask (M) - useful when examining the mask for drawing accuracy and feathering effect.
    • Only Display Mask When Drawing - the recommended option for quick drawing.
    • Display Grayscale Mask (Alt-M) - useful option to verify the accuracy of mask edges, including the overall effectiveness of the selection when inverted.
    • Never Display Mask (M) - used when drawing individual local adjustments directly to the image or layer.
  3.  Use the keyboard shortcut (M) or (Alt-M) respectively, to toggle the mask on or off.
  4. You can also access the Mask display options by going to the menu and choosing Layer > Mask Visibility >

Changing the color of the mask

The mask created when making a selection is displayed as a semi-transparent red color. This default color can be changed from the Preferences.

  1. From the main menu, go to Capture One > Preferences… (⌘,) Mac, or Edit > Preferences (Windows). The Preferences dialog window opens.
  2. Select the Appearance tab, then under Layers, click-on the Mask Color box. Depending on the OS, a color dialog window opens.
  3. Select the color from the choices available. The chosen hue will added to the Mask Color box.
  4. Close the Preferences window and the mask color will be enabled. There’s no need to restart the application.
  5. If a mask has already been created, click on the Display Mask (M) option in the Layers tool to update the color.
  6. To return to the default, reopen the Appearance tab and click on the Default button at the bottom of the page. Note, any other changes on that page will also be returned to the default settings.

Using selection points

A single selection point will appear close to the first application of a mask in an adjustment layer or in a repair layer. One Selection point will appear per layer, and will change color from silver to orange when active. Clicking on one will select that layer in the Layers tool, making it a quick and efficient way to move between them when editing, if there are several associated with that image.

  1. To enable the layer selection points, go the the menu and choose Layer > Layer Selection Points and ensure that the option is toggled on.
  2. To move between layers, click on the relevant selection point in the Viewer. Note, the selection point will change from silver to orange when selected. Toggle Display Mask (M), or Display Grayscale Mask (Alt-M) to view the selection. 
  3. To move the masked area, click the selection point and drag to the desired location. The mask will move with the selection point.
  4. When the Show Selection Point isn't already enabled, cmd/ctrl-click on the mask instead and then drag to the new position.

Keyboard shortcuts

The Shortcut manager has been expanded to include a number of commands so that you can add your own customized keyboard shortcuts when working with layers. Shortcuts greatly improve the efficiency of your workflow. The shortcut manager is accessed from the main menu under Edit > Edit Keyboard Shortcuts... For more information on the subject, see the section on Keyboard Shortcuts.

Modifying the size of the Layers tool panel

Like a number of the tools in Capture One, the size of the Layers tool’s panel can be adjusted to accommodate the number of layers in use.This is especially useful where there can be as many as 16 individual layers to display and work with. Along with two fixed size options an Auto size option varies the size of the window depending on the size of the other tools’ windows in the tool tab, when either opened or closed. Note, it may be possible to increase the size of the window by closing others in the same inspector. Note also that, certain tools can be resized when removed from the inspector to float in the viewer.

  1. In the Layers tool's title bar, click on the Action menu (…) icon. The Action menu opens.
  2. Select from the following choices:
    • Small Size (fixed)
    • Medium Size (fixed)
    • Auto Size (automatically determined by the size of the other tools’ windows in the inspector)
  3. The window size is saved automatically.